"Back to shop" is not redirecting


#1

Yesterday I removed my domain name from the “Connect your shop and web site” field under Advanced Settings | Embed Shop in Website.

Today I added it back and updated the shop, but an hour later the “Back to shop” links are not redirecting to my web site. It was redirecting yesterday, prior to my removing the domain; and it seemed to end redirection the moment I removed my URL.

Do I just need to wait longer, or am I doing something wrong? Thanks!

(Clearing the browser page cache didn’t help.)

UPDATE: After posting this, I logged out and back in, and the URL did not appear in the field any more. I re-entered the URL and re-applied the changes. After logging out and back in again, the URL is sticking this time. It’s still not redirecting. I guess I’m waiting anew?

RESOLVED: There must have been a bug the first time around that persisted the URL in the shop settings and pretended to apply them but which did neither. This time around, after logging out and back in, noticing the the URL had not been stored, re-entering the URL, and re-applying the settings, redirection began working again after just a few minutes.


#2

phew. yes, sometimes cacheing is a bitch.
but good to know that it worked lately!