Cannot edit designs or create new products

Ever since I was moved to the new partner area, I cannot make changes to my designs or create new products. I have been trying for four days now, and every time I get the same error when I try to save my changes.

A I the only one having this problem? Am I missing something? Anybody got any ideas?

Let me check with our developers!

Hi Maurice,

maybe it is a buck, but I have the same Problem when I use shortcut St. instead of writing street.
Because I didn’t see what you put in, it is just an idea.

Same thing happening to me. What a mess.

I did abbreviate road to Rd, so I tried it written out. No change. Thanks anyway, though.

It’s really frustrating; I’d like to get some products pushed out into the marketplace.

Is there any update on this issue? I’d really like to get some products out.

Sorry that it didn’t help, like I know is that use google maps for control if the address is ok.
So may you look if google maps write you address different and try it like google write it if it will be different.
If not I hope Lena can help you fast!

This was just fixed!

Hey! It works now! thanks for the quick action, guys! I appreciate it!

1 Like


I have been having this exact issue every time i have tried to create a design including today.

Is it to do with the address or something else?

Many Thanks

Same same. Simply want to delete and/or add products but can’t.

Have forwarded the issue and hope it will be solved today :slight_smile: